PDA

View Full Version : RSA - Invalid Key / CAN controller not available error



cvrettacos
03-21-2018, 10:35 AM
Getting the following pop-ups whenever I try to use Maintenance Tool (release V03.03.06.347696.350) to connect to a Cr2532. I uninstalled & re-installed Maintenance Tool without any luck. No issues connecting to the Cr2532 with CoDeSys. I?m running Windows 7 Professional, Service Pack 1.

Any advice on how to resolve would be greatly appreciated. Thanks.

369

Erik Gerrits
03-21-2018, 11:15 AM
That's odd. Can you connect to any other device? Does the CAN Utility work?

cvrettacos
03-22-2018, 12:10 PM
Same thing happens in CAN utility & with other Basic devices. I think something just got hosed with my computer, but re-installing Maintenance Tool isn't resolving the issue.

Erik Gerrits
03-22-2018, 02:19 PM
Do you have a Peak or Ixxat device? If so does it do it with that?

Maybe you got a different version of the CANfox MT API installed. It should be version 7.4.44.0. You could try uninstalling anything related to Seica or Sontheim then reinstall the Maintenance Tool.

370

cvrettacos
03-22-2018, 04:07 PM
I was originally using a PEAK. Tried the CANfox & it works fine. I am running version 7.4.44.0 of the CANfox MT API. Is it still worth uninstalling/reinstalling the Seica or Sontheim stuff for the PEAK?

Erik Gerrits
03-22-2018, 06:54 PM
You can’t use the CAN Utility with PEAK. You should be able to download though.

I wouldn’t bother with reinstalling the Sieca and Sontheim items.

cvrettacos
03-23-2018, 07:24 AM
I uninstalled the Sieca and Sontheim items & reinstalled Maintenance Tool before reading your response & it ended up fixing my issue. I can now use the PEAK adapter again to connect with Maintenance Tool. Thanks for the help.

Erik Gerrits
03-23-2018, 09:21 AM
I uninstalled the Sieca and Sontheim items & reinstalled Maintenance Tool before reading your response & it ended up fixing my issue. I can now use the PEAK adapter again to connect with Maintenance Tool. Thanks for the help.

Thanks for the update.