PDA

View Full Version : Maintenance Tool Issue w/ PEAK Adapter: BMAS_ERROR_SUB_SERVICE_UNKNOWN



cvrettacos
02-07-2019, 04:10 PM
We've got a customer who's running Maintenance_3.4.6.359903.314 & gets a BMAS_ERROR_SUB_SERVICE_UNKNOWN when trying to connect to a Cr0403. They can use they PEAK adapter w/ CoDeSys to connect the the Cr0403, which is old & needs a firmware upgrade to accept the current application software. When using CoDeSys they get the "PLC Configuration doesn't match" error. Does the BMAS_ERROR shed any light on what we need to do to correct their issue? Thanks.

Erik Gerrits
02-08-2019, 12:36 PM
How old is the PLC? Can read the Identity?

cvrettacos
02-08-2019, 02:31 PM
The Cr0403 has a date code of "AC". Didn't have them try to read the Identity, but did have them try to Read Channel Parameters, that's when the error message comes up. Same customer, using same laptop & Maintenance Tool, along with a CANFox adapter, was able to connect to a Cr0403 about a month ago. Customer downloaded, & installed, latest PEAK adapter driver yesterday before we ran into this problem.

Erik Gerrits
02-13-2019, 09:08 AM
I wonder if the firmware is old enough that it doesn't support the Read Channel Parameters. This feature will not work if you do not have firmware on the PLC as well.

cvrettacos
02-13-2019, 01:52 PM
Customer sent me the Cr0403. I'm running Maintenance V03.03.06 & I'm getting that same error. It comes up immediately when I try READ CH PARAM. I can do IDENTITY & it'll update (software version on unit is V01.03.03 / manufacture date 5/4/2013), but then that error pops up & kills comms, so I can't update the firmware.

cvrettacos
02-14-2019, 08:24 AM
Got the unit squared away. I had forgotten about the FORCE BOOTLOADER MODE function in Maintenance Tool. Wolfgang was kind enough to point it out to me yesterday.