Results 1 to 6 of 6

Thread: Maintenance Tool Issue w/ PEAK Adapter: BMAS_ERROR_SUB_SERVICE_UNKNOWN

  1. #1
    Join Date
    May 2009
    Posts
    87

    Default Maintenance Tool Issue w/ PEAK Adapter: BMAS_ERROR_SUB_SERVICE_UNKNOWN

    We've got a customer who's running Maintenance_3.4.6.359903.314 & gets a BMAS_ERROR_SUB_SERVICE_UNKNOWN when trying to connect to a Cr0403. They can use they PEAK adapter w/ CoDeSys to connect the the Cr0403, which is old & needs a firmware upgrade to accept the current application software. When using CoDeSys they get the "PLC Configuration doesn't match" error. Does the BMAS_ERROR shed any light on what we need to do to correct their issue? Thanks.

  2. #2
    Join Date
    May 2009
    Location
    Minneapolis, MN
    Posts
    295

    Default

    How old is the PLC? Can read the Identity?

  3. #3
    Join Date
    May 2009
    Posts
    87

    Default

    The Cr0403 has a date code of "AC". Didn't have them try to read the Identity, but did have them try to Read Channel Parameters, that's when the error message comes up. Same customer, using same laptop & Maintenance Tool, along with a CANFox adapter, was able to connect to a Cr0403 about a month ago. Customer downloaded, & installed, latest PEAK adapter driver yesterday before we ran into this problem.

  4. #4
    Join Date
    May 2009
    Location
    Minneapolis, MN
    Posts
    295

    Default

    I wonder if the firmware is old enough that it doesn't support the Read Channel Parameters. This feature will not work if you do not have firmware on the PLC as well.

  5. #5
    Join Date
    May 2009
    Posts
    87

    Default

    Customer sent me the Cr0403. I'm running Maintenance V03.03.06 & I'm getting that same error. It comes up immediately when I try READ CH PARAM. I can do IDENTITY & it'll update (software version on unit is V01.03.03 / manufacture date 5/4/2013), but then that error pops up & kills comms, so I can't update the firmware.

  6. #6
    Join Date
    May 2009
    Posts
    87

    Default

    Got the unit squared away. I had forgotten about the FORCE BOOTLOADER MODE function in Maintenance Tool. Wolfgang was kind enough to point it out to me yesterday.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •